Dart kostenlos downloaden vollversion

Benötigen Sie eine bestimmte Version oder einen anderen Download? Siehe Index der Downloads. Stabile Kanalversionen des Dart SDK haben x.y.z-Versionszeichenfolgen wie 1.24.3 und 2.1.0. Sie bestehen aus punktgetrennten Ganzzahlen ohne Bindestriche oder Buchstaben, wobei x die Hauptversion, y die Nebenversion und z die Patch-Version ist. Hinweis: Flutter verlässt sich auf eine vollständige Installation von Android Studio, um seine Android-Plattformabhängigkeiten zu liefern. Sie können Ihre Flutter-Apps jedoch in einer Reihe von Editoren schreiben. in einem späteren Schritt wird dies erläutert. Wenn Sie keine feste Version des Installationspakets installieren möchten, können Sie die Schritte 1 und 2 überspringen. Holen Sie stattdessen den Quellcode aus dem Flutter-Repository auf GitHub ab, und ändern Sie nach Bedarf Verzweigungen oder Tags. Beispiel: Beta- und Entwicklungskanalversionen des Dart SDK (nicht stabile Releases) haben x.y.z-a.b.-beta|dev>-Versionen wie 2.8.0-20.11.beta. Der Teil vor dem Bindestrich folgt dem Stabilversionsschema, a und b nach dem Bindestrich sind die Prerelease- und Prerelease-Patchversionen, und Beta oder Dev ist der Kanal. Wie oben gezeigt, stammen die beiden Befehle nicht aus demselben Bin-Verzeichnis. Aktualisieren Sie Ihren Pfad, um Befehle aus /bin vor Befehlen von /usr/local/bin (in diesem Fall) zu verwenden.

Nachdem Sie die Shell aktualisiert haben, damit die Änderung wirksam wird, sollte das Ausführen des Befehls which oder where erneut zeigen, dass die Befehle flatterter und dart nun aus demselben Verzeichnis stammen. Um zwischen lokal installierten Dart-Releases zu wechseln, verwenden Sie Brew-Switch-Dart-. Beispiel: Alternativ laden Sie Dart SDK als Debian-Paket im .deb-Paketformat herunter. Wichtig: Dart Editor für Linux ist nur für Ubuntu. Wenn Sie Debian oder eine andere Nicht-Ubuntu-Distribution verwenden, sollten Sie genau das herunterladen, was Sie brauchen, und einen anderen Editor auswählen. Dieser Befehl überprüft Ihre Umgebung und zeigt einen Bericht über den Status Ihrer Flutter-Installation an. Überprüfen Sie die Ausgabe sorgfältig für andere Software, die Sie möglicherweise installieren müssen, oder weitere Aufgaben auszuführen (in Fettschrift dargestellt). Wie die folgenden Anweisungen zeigen, können Sie einen Paket-Manager verwenden, um ein stabiles Channel Dart SDK einfach zu installieren und zu aktualisieren. Alternativ können Sie das SDK aus der Quelle erstellen oder von jedem Releasekanal installieren, indem Sie das SDK als ZIP-Datei herunterladen.

Um mehr über den Dart-Befehl zu erfahren, führen Sie dart -h aus der Befehlszeile aus, oder sehen Sie sich die Dart-Tool-Seite auf dart.dev an. Verwenden Sie dieses Archiv, um bestimmte Versionen des Dart SDK und der Dart API-Dokumentation herunterzuladen. Sie können stabile Kanalversionen mithilfe der obigen Anweisungen erhalten, oder Sie können stabile, Beta- oder Entwicklungskanalversionen mit einem Paket-Manager oder durch Herunterladen des SDK als ZIP-Datei erhalten. Wenn Sie Dart Editor herunterladen, erhalten Sie auch das SDK und die Möglichkeit, automatisch zu aktualisieren. Hinweis: Ab Flutters 1.19.0-Entwicklungsversion enthält das Flutter SDK den Dart-Befehl neben dem Flutter-Befehl, sodass Sie Dart-Befehlszeilenprogramme einfacher ausführen können. Wenn Sie das Flutter SDK herunterladen, wird auch die kompatible Version von Dart heruntergeladen, aber wenn Sie das Dart SDK separat heruntergeladen haben, stellen Sie sicher, dass die Flutter-Version von dart zuerst in Ihrem Pfad ist, da die beiden Versionen möglicherweise nicht kompatibel sind.

អត្ថបទ ដែលទាក់ទង